Prerequisites
  • 18 Apr 2022
  • 1 Minute to read
  • Dark
    Light
  • PDF

Prerequisites

  • Dark
    Light
  • PDF

Downloading Euclid Studio

All required Euclid Studio files can be downloaded from the QueBIT software portal https://quebit.com/software-access/.

Installation files include:

  1. The main .war file under the current version number:
    • EuclidStudio.war

  2. Prerequisite install files under Installation Files (unzip):
    • apache-tomcat-9.x.x.exe
    • python-x.x.x-amd64.exe
    • R-x.x.x-win.exe
    • Java Runtime (choose only one)
      • OpenJDK8U-jdk_x64_windows_hotspot_8u292b10.msi (Free)
      • jre-8u261-windows-x64.exe (Paid commercial support required download on Oracle website)
    • Tomcat lib files under Installation Files/put_these_files_in_tomcat_lib (unzip):
      • cdi-api-1.2.jar
      • jsf-api-2.2.9.jar
      • jsf-impl-2.2.9.jar
      • jstl-1.2.jar

Other Prerequisites

Licensing

Additional information on licensing & registration can be found in the License Requirements topic.

Hardware Requirements

  • Windows (Server 2016+) or Linux (Ubuntu 20.04 or similar)
  • 64 GB RAM
  • 500 GB Disk+
  • 8 Cores
  • Java 1.8 SDK
  • Apache Tomcat 9.0+
  • Network share recommended for storing workflows and models

Software Requirements

  • Web Browser
  • Python (3.6+) and R executables optional but suggested

Additional Datasource Prerequisites

Euclid Studio is designed to be configured with one or more connections to source data systems. Depending on your intended use additional configuration may be required.


Was this article helpful?